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 AVR® DA 系列入门

简介

作者： Alin Stoicescu，Microchip Technology Inc.

本应用笔记概述 AVR® DA 系列单片机的入门信息。

有关 AVR® DA 系列器件之间差异的更多信息，请参见数据手册。

本文档介绍的内容

• AVR® DA 系列单片机和工具入门

• AVR128DA48 Curiosity Nano 和 Atmel Studio 7.0 入门

• AVR128DA48 Curiosity Nano 和 MPLAB® X 入门
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1. 相关器件
本节列出了本文档的相关器件。下图给出了不同系列的器件之间的关系，并注明了不同的引脚数与存储器大小：

• 从下到上迁移无需修改代码，因为这些器件的引脚彼此兼容，后者可提供相同甚至更多的功能

• 从右到左迁移会减少引脚数，进而减少可用的功能

• 具有不同闪存大小的器件通常也具有不同的 SRAM 和 EEPROM

图 1-1. AVR® DA 系列概览
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2. 获取器件数据手册
产品页面

• AVR32DA28： www.microchip.com/wwwproducts/en/AVR32DA28
• AVR32DA32： www.microchip.com/wwwproducts/en/AVR32DA32
• AVR32DA48： www.microchip.com/wwwproducts/en/AVR32DA48
• AVR64DA28： www.microchip.com/wwwproducts/en/AVR64DA28
• AVR64DA32： www.microchip.com/wwwproducts/en/AVR64DA32
• AVR64DA48： www.microchip.com/wwwproducts/en/AVR64DA48
• AVR64DA64： www.microchip.com/wwwproducts/en/AVR64DA64
• AVR128DA28： www.microchip.com/wwwproducts/en/AVR128DA28
• AVR128DA32： www.microchip.com/wwwproducts/en/AVR128DA32
• AVR128DA48： www.microchip.com/wwwproducts/en/AVR128DA48
• AVR128DA64： www.microchip.com/wwwproducts/en/AVR128DA64

文档

• AVR DA 产品简介（.pdf）
• AVR128DA 数据手册（.pdf）
• AVR64DA 数据手册（.pdf）
• AVR32DA 数据手册（.pdf）
• AVR128DA 硅片勘误表和数据手册说明（.pdf）
• AVR64DA 硅片勘误表和数据手册说明（.pdf）
• AVR32DA 硅片勘误表和数据手册说明（.pdf）

AVR® DA 系列的文档分为两种类型：

• 数据手册(1)（包含器件说明、外设数量、引脚排列和电气特性）

• 勘误表（包含器件的已知勘误）

注：

1. 对于尚未发布的器件，可以使用产品简介而不是数据手册。

 AN3429
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3. 获取工具
Atmel Studio 7.0 采用 GCC 编译器，开始使用 AVR® DA 系列时可以用作 IDE。

MPLAB® X 采用 GCC 编译器或 XC8 编译器，开始使用 AVR® DA 系列时可以用作 IDE。

3.1 获取 AVR128DA48 Curiosity Nano 评估工具包

图 3-1. AVR128DA48 Curiosity Nano 工具包

网页： www.microchip.com/developmenttools/ProductDetails/DM164151

获取工具包： www.microchipdirect.com/product/search/all/DM164151

文档/文件：

• AVR128DA48 Curiosity Nano （.pdf）

主要特性

• AVR128DA48 单片机

• 1 个黄色用户 LED
• 1 个机械用户开关

• 1 个 32.768 kHz 晶振

• 板上调试器

– Atmel Studio/Microchip MPLAB X 中的评估板标识

– 1 个绿色电源和状态 LED
– 编程和调试

– 虚拟 COM 端口（CDC）

– 两个逻辑分析器通道（DGI GPIO）

• USB 供电

• 可调目标电压

– MIC5353 LDO 稳压器，由板上调试器控制

– 1.8-5.1V 输出电压（受 USB 输入电压限制）

– 500 mA 最大输出电流（受环境温度和输出电压限制）

AVR128DA48 Curiosity Nano 用户指南介绍了如何为工具包供电，并提供有关评估板元件、扩展接口和硬件指南的详

细信息。

3.2 从 Atmel START 获取代码示例

代码示例可通过 Atmel START 获得，Atmel START 是一种基于 Web 的工具，可通过图形用户界面（Graphical User
Interface，GUI）配置应用程序代码。通过下面的示例代码直接链接或通过 Atmel START 主页上的 Browse
Examples（浏览示例）按钮，可以为 Atmel Studio、MPLAB X 和 IAR Embedded Workbench®下载代码。
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Atmel START 网页：Atmel START。

代码示例

可通过在 Atmel START 示例浏览器中搜索器件名称（例如，AVR128DA48）来查找 AVR DA 系列器件的代码示例。

有关详细信息和示例项目的相关信息，请单击 Atmel START 中的 User Guide（用户指南）。User Guide 按钮位于示

例浏览器中，在 Atmel START 项目配置器中的仪表板视图中单击项目名称即可看到。

Atmel Studio

在 Atmel START 的示例浏览器中单击 Download Selected example（下载所选示例），下载 Atmel Studio 对应的代

码并保存为.atzip文件。要从 Atmel START 下载文件，单击 Export project（导出项目），然后单击 Download
pack（下载数据包）。

双击下载的.atzip文件，将项目导入到 Atmel Studio 7.0。

MPLAB® X

单击 Export project，然后单击 Download pack 从 Atmel START 下载 MPLAB X IDE 对应的代码并保存为.atzip
文件。

要在 MPLAB X 中打开 Atmel START 示例，从 MPLAB X 中的菜单选择 File > Import > START MPLAB Project（文

件 > 导入 > START MPLAB 项目），并导航到.atzip文件。

IAR Embedded Workbench®

有关如何在 IAR Embedded Workbench 中导入项目的信息，请打开 Atmel START User Guide（Atmel START 用户指

南），选择 Using Atmel Start Output in External Tools（使用外部工具中的 Atmel Start 输出），然后选择 IAR
Embedded Workbench。单击 Atmel START 起始页右上角的 Help（帮助）或项目配置器中右上角的 Help And
Support（帮助和支持），均可找到 Atmel START 用户指南的链接。

3.3 从 GitHub 获取代码示例
示例代码可通过 GitHub 获得，GitHub 是一个基于 Web 的服务器，可通过图形用户界面（GUI）提供应用程序代码。

代码示例可在 Atmel Studio 或 MPLAB X 中打开。要在 MPLAB X 中打开 Atmel Studio 项目，从 MPLAB X 的菜单中选

择 File > Import > Atmel Studio Project（文件>导入>Atmel Studio 项目），然后导航至.cproj文件。

GitHub 网页：GitHub.

代码示例

可通过在 GitHub 示例浏览器中搜索器件名称（例如，AVR128DA48）来查找 AVR DA 系列器件的代码示例。

View Code Examples on GitHub
Click to browse repositories

单击 Clone（克隆）或 download（下载）按钮从 GitHub 的示例页面下载代码，并保存为.zip文件。

3.4 获取 Atmel Studio 7.0
网页： www.microchip.com/development-tools/atmel-studio-7

文档/文件：

• Atmel Studio 7.0（补丁 2397 或更高版本）

为 AVR® DA 系列开发和调试固件时，可将 Atmel Studio 7.0 作为 IDE 使用。

要了解器件支持，请参见 3.5.  获取对 Atmel Studio 的器件支持。

 AN3429
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3.5 获取对 Atmel Studio 的器件支持

Atmel Studio：可转至 Tools → Device Pack Manager（工具 -> 器件包管理器），使用 Device Pack Manager 在
Atmel Studio 中添加对新器件的支持。

对于 AVR® DA 系列，可通过以下步骤更新到最新版本：

1. 单击 Check for Updates（检查更新）。

2. 对于 AVR® DA 系列，选择 AVR-Dx_DFP 的最新版本。

3. 单击 Install（安装）。

对于离线安装程序，请转至 packs.download.atmel.com/。要安装软件包，请双击安装程序文件并按照说明进行操作。

必须关闭所有打开的 Atmel Studio 窗口才能使安装生效。

IAR：可以通过安装最新的服务包在 IAR Embedded Workbench 中添加对新器的支持。服务包可以从 https://iar.com
上的 My Pages（我的页面）获得。

3.6 获取 MPLAB® X
网页： MPLAB® X IDE

文档/文件：

• MPLAB X

为 AVR® DA 系列开发和调试固件时，可将 MPLAB X 作为 IDE 使用。

要了解器件支持，请参见 3.7.  获取对 MPLAB X 的器件支持。

3.7 获取对 MPLAB® X 的器件支持

MPLAB X：可转至 Tools → Packs（工具 -> 包），使用 MPLAB Pack Manager 在 MPLAB X 中添加对新器件的支

持。

对于 AVR® DA 系列，可通过以下步骤更新到最新版本：

1. 单击 Check for Updates。
2. 对于 AVR® DA 系列，选择 AVR-Dx_DFP 的最新版本。

3. 单击 Install。

对于离线安装程序，请转至 packs.download.microchip.com/。要安装软件包，请双击安装程序文件并按照说明进行操

作。必须关闭所有打开的 MPLAB X 窗口才能使安装生效。

3.8 获取 MPLAB®代码配置器

网页： MPLAB®代码配置器

文档/文件：

• MCC

可以在 MPLAB X IDE 内将 MPLAB 代码配置器作为图形编程界面使用，为 AVR® DA 系列生成外设和库的代码。

3.9 获取适用于 AVR®的 IAR Embedded Workbench®

网页： https://www.iar.com/iar-embedded-workbench/#!?architecture=AVR

文档/文件：适用于 AVR 的 IAR Embedded Workbench 安装程序。
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4. Atmel Studio 用户入门

4.1 Atmel Studio 搭配 AVR128DA48 Curiosity Nano
AVR128DA48 Curiosity Nano 前提条件

• 安装 Atmel Studio 7.02397 或更高版本

• AVR128DA48 Curiosity Nano 板通过板上 USB 连接器连接到 Atmel Studio 7.0，而 USB 连接器则连接到嵌入式

调试器。工具包将由 USB 供电，嵌入式调试器将通过 USB 进行调试和编程。

工作流程

1. 启动 Atmel Studio 7.0。
2. 当 AVR128DA48 Curiosity Nano 连接到 Atmel Studio 7.0 时，将出现图 4-1 所示的页面。

图 4-1. AVR128DA48 Curiosity Nano Atmel Studio 中的页面

3. 单击 New → Project...（新建 → 项目...）或使用快捷键 Ctrl+Shift+N，开始创建新项目，如图 4-2 所示。
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图 4-2. 在 Atmel Studio 中创建新项目

4. 如图 4-3 所示，选择 GCC C Executable Project（GCC C 可执行项目）模板，键入解决方案和项目的名称

（例如，GETTING_STARTED 和 LED_TOGGLE），然后单击 OK（确定）。

图 4-3. New project（新建项目）向导

5. 选择图 4-4 中的 AVR128DA48，然后单击 OK。
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图 4-4. Device Selection（器件选择）向导

将在 Atmel Studio 中生成一个新项目以及与该项目相关联的 main.c文件。

6. 将 main.c文件替换为以下代码段：

int main (void)
{
  /* 将 SW0配置为输入 */
  PORTC.DIRCLR = PIN7_bm;

  /* 将 LED0引脚配置为输出 */
  PORTC.DIRSET = PIN6_bm;

  /* 使能 SW0的内部上拉 */
  PORTC.PIN7CTRL |= PORT_PULLUPEN_bm;

  while (1) 
  {
    /* 检查 SW0的状态 */
    /* 0：已按下 */
    if (!(PORTC.IN & (PIN7_bm)))
    {
      /* LED0点亮 */
      PORTC.OUTSET = PIN6_bm;
    }
    /* 1：已释放 */
    else
    {

  /* LED0熄灭 */
     PORTC.OUTCLR = PIN6_bm;
    }
  }
}

在代码编辑器中，代码将如图 4-5 所示。
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图 4-5. 代码编辑器窗口

7. 单击 Project → Properties（项目 → 属性）或使用快捷键 ALT+F7，打开项目属性。

8. 在 Tool（工具）视图中（见图 4-6），将 Selected debugger/programmer（选定调试器/编程器）设置为

nEDBG，将 Interface（接口）设置为 UPDI。
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图 4-6. AVR128DA48 的调试器和接口

9. 单击 Build→Build Solution（编译→编译解决方案）或使用快捷键 F7，编译项目。

10. 单击 Debug → Start debugging and break（调试 → 开始调试并中断）或使用快捷键 ALT+F5，为

AVR128DA48 编程项目代码并开始调试。应用程序被烧写到器件上，程序执行应在 main()函数内产生中断。

11. 单击 Debug → Continue（调试 → 继续）或使用快捷键 F5 运行代码。

12. 验证 AVR128DA48 Curiosity Nano 上的 SW0 按下时，LED0 是否点亮。
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5. MPLAB® X用户入门

5.1 MPLAB® X 搭配 AVR128DA48 Curiosity Nano
前提条件

• MPLAB X 已安装

• 通过与嵌入式调试器相连的板上 USB 插口将 AVR128DA48 Curiosity Nano 板连接到 MPLAB X。工具包将由

USB 供电，嵌入式调试器将通过 USB 进行调试和编程。

工作流程

1. 启动 MPLAB X。
2. 当 AVR128DA48 Curiosity Nano 连接到 MPLAB X 时，将出现图 5-1 所示的页面。

图 5-1. AVR128DA48 Curiosity Nano MPLAB® X 中的页面

3. 单击 File → New Project...（文件 → 新建项目...）或使用快捷键 Ctrl+Shift+N，开始创建新项目，如图 5-2 所

示。
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图 5-2. 在 MPLAB® X 中创建新项目

4. 选择图 5-6 中的 Categories → Microchip Embedded（类别 → Microchip 嵌入式）和 Projects →
Standalone Project（项目 → 独立项目）模板，然后单击 Next（下一步）。
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图 5-3. 新建项目窗口

5. 选择图 5-4 中的 AVR128DA48，然后单击 Next。

 AN3429
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图 5-4. 器件选择窗口

然后选择评估板和所需的编译器（如果存在）。

6. 输入项目名称（如 LED_TOGGLE）和项目位置（如 C:\microchip），然后单击 Finish（完成）。
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图 5-5. 项目名称和位置选择窗口

7. 单击 File → New File...（文件 → 新建文件...）或使用快捷键 Ctrl+N 创建一个新的 main.c文件，如图 5-6 所

示。
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图 5-6. 在 MPLAB® X 中创建一个新文件

8. 选择图 5-7 中的 Categories → C（类别 → C）和 File Types → C Main File（文件类型 → C 主文件）模板，

然后单击 Next。

 AN3429
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图 5-7. 新建文件窗口

9. 输入文件名（如 main），然后单击 Finish。

 AN3429
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图 5-8. 文件名窗口

10. 将 main.c文件替换为以下代码段：

int main (void)
{
  /* 将 SW0配置为输入 */
  PORTC.DIRCLR = PIN7_bm;

  /* 将 LED0引脚配置为输出 */
  PORTC.DIRSET = PIN6_bm;

  /* 使能 SW0的内部上拉 */
  PORTC.PIN7CTRL |= PORT_PULLUPEN_bm;

  while (1) 
  {
    /* 检查 SW0的状态 */
    /* 0：已按下 */
    if (!(PORTC.IN & (PIN7_bm)))
    {
      /* LED0点亮 */
      PORTC.OUTSET = PIN6_bm;
    }
    /* 1：已释放 */
    else
    {
      /* LED0熄灭 */
      PORTC.OUTCLR = PIN6_bm;
    }
  }
}

在 main.c 中添加#inlude<avr/io.h>。在代码编辑器中，代码将如图 5-9 所示。
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图 5-9. 代码编辑器窗口

11. 通过单击 Production → Clean and Build Main Project（生产 → 清除并编译主项目）或使用快捷键 Shift +
F11 编译代码。

12. 通过单击 Debug → Debugging Main Project（调试 → 调试主项目）使用项目代码编程 AVR128DA48 并开始

调试。

13. 验证 AVR128DA48 Curiosity Nano 上的 SW0 按下时，LED0 是否点亮。
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6. 其他信息
有关 AVR 产品和 IDE 的更多信息，请参见以下链接：

软件：

• Atmel Studio
• Atmel Studio 帮助：Help → View Help（帮助 → 查看帮助），也可使用快捷键 CTRL+F1。
• Microchip Gallery
• MPLAB X

固件：

• Atmel START 文档

• Atmel START 示例

• GitHub 示例

硬件：

• AVR042：AVR 硬件设计考虑因素

• AVR IBIS 文件

• AVR BDSL 文件

推荐的编程/调试工具：

• Atmel-ICE：
– 用户指南

– 购买

• 功率调试器：

– 用户指南

– 购买

其他：

• AVR Freaks®： www.avrfreaks.net/
• 应用笔记：请点击 www.microchip.com/paramChartSearch/chart.aspx?branchID=30047，找到首选器件并转到产

品页面。所有相关的应用笔记都可以在 Documents（文档）选项卡下找到。

• AVR 产品选型： www.microchip.com/paramChartSearch/chart.aspx?branchID=30047
• 有关各种产品的更多技术文档：https://www.microchip.com/webdoc
• Microchip 技术支持： www.microchip.com/support/hottopics.aspx
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7. 版本历史

文档版本 日期 备注

B 2020 年 5 月 根据最新商标，将 AVR® MCU DA (AVR-DA)更新为 AVR® DA MCU，AVR-DA 更新为

AVR DA。

A 2020 年 03 月 文档初始版本
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Microchip 网站

Microchip 网站（www.microchip.com/）为客户提供在线支持。客户可通过该网站方便地获取文件和信息。我们的网站

提供以下内容：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及硬件支持文档、最新的软件版
本以及归档软件

• 一般技术支持——常见问题解答（FAQ）、技术支持请求、在线讨论组以及 Microchip 设计伙伴计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动安排表、Microchip 销售办事

处、代理商以及工厂代表列表

产品变更通知服务

Microchip 的产品变更通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在他们感兴趣的某个产品系列

或开发工具发生变更、更新、发布新版本或勘误表时，收到电子邮件通知。

欲注册，请访问 www.microchip.com/pcn，然后按照注册说明进行操作。

客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师（ESE）
• 技术支持

客户应联系其代理商、代表或 ESE 寻求支持。当地销售办事处也可为客户提供帮助。本文档后附有销售办事处的联系

方式。

也可通过 www.microchip.com/support 获得网上技术支持。

Microchip 器件代码保护功能

请注意以下有关 Microchip 产品代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术规范。

• Microchip 确信：在正常使用且符合工作规范的情况下，Microchip 系列产品非常安全。

• Microchip 注重并积极保护其知识产权。严禁任何试图破坏 Microchip 产品代码保护功能的行为，这种行为可能会

违反《数字千年版权法案》（Digital Millennium Copyright Act）。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是“牢不可破”

的。代码保护功能处于持续发展中。Microchip 承诺将不断改进产品的代码保护功能。

法律声明

提供本文档的中文版本仅为了便于理解。请勿忽视文档中包含的英文部分，因为其中提供了有关 Microchip 产品性能和

使用情况的有用信息。Microchip Technology Inc.及其分公司和相关公司、各级主管与员工及事务代理机构对译文中可

能存在的任何差错不承担任何责任。建议参考 Microchip Technology Inc.的英文原版文档。

本出版物及其提供的信息仅适用于 Microchip 产品，包括设计、测试以及将 Microchip 产品集成到您的应用中。以其他

任何方式使用这些信息都将被视为违反条款。本出版物中的器件应用信息仅为您提供便利，将来可能会发生更新。如

需额外的支持，请联系当地的 Microchip 销售办事处，或访问 https://www.microchip.com/en-us/support/design-help/
client-supportservices。

 AN3429

© 2022 Microchip Technology Inc.
及其子公司

 应用笔记 DS00003429B_CN-第 24 页

http://www.microchip.com/
http://www.microchip.com/pcn
http://www.microchip.com/support


Microchip“按原样”提供这些信息。Microchip 对这些信息不作任何明示或暗示、书面或口头、法定或其他形式的声明

或担保，包括但不限于针对非侵权性、适销性和特定用途的适用性的暗示担保，或针对其使用情况、质量或性能的担

保。

在任何情况下，对于因这些信息或使用这些信息而产生的任何间接的、特殊的、惩罚性的、偶然的或间接的损失、损

害或任何类型的开销，Microchip 概不承担任何责任，即使 Microchip 已被告知可能发生损害或损害可以预见。在法律

允许的最大范围内，对于因这些信息或使用这些信息而产生的所有索赔，Microchip 在任何情况下所承担的全部责任均

不超出您为获得这些信息向 Microchip 直接支付的金额（如有）。如果将 Microchip 器件用于生命维持和/或生命安全应

用，一切风险由买方自负。买方同意在由此引发任何一切损害、索赔、诉讼或费用时，会维护和保障 Microchip 免于承

担法律责任。除非另外声明，在 Microchip 知识产权保护下，不得暗中或以其他方式转让任何许可证。

商标

Microchip 的名称和徽标组合、Microchip 徽标、Adaptec、AnyRate、AVR、AVR 徽标、AVR Freaks、BesTime、 

BitCloud、CryptoMemory、CryptoRF、dsPIC、flexPWR、HELDO、IGLOO、JukeBlox、KeeLoq、Kleer、 

LANCheck、LinkMD、maXStylus、maXTouch、MediaLB、megaAVR、Microsemi、Microsemi 徽标、MOST、 

MOST 徽标、MPLAB、OptoLyzer、PIC、picoPower、PICSTART、PIC32 徽标、PolarFire、Prochip Designer、 

QTouch、SAM-BA、SenGenuity、SpyNIC、SST、SST 徽标、SuperFlash、Symmetricom、SyncServer、 

Tachyon、TimeSource、tinyAVR、UNI/O、Vectron 及 XMEGA 均为 Microchip Technology Incorporated 在美国和其

他国家或地区的注册商标。

AgileSwitch、APT、ClockWorks、The Embedded Control Solutions Company、EtherSynch、Flashtec、Hyper 
Speed Control、HyperLight Load、IntelliMOS、Libero、motorBench、mTouch、Powermite 3、Precision Edge、 

ProASIC、ProASIC Plus、ProASIC Plus 徽标、Quiet-Wire、SmartFusion、SyncWorld、Temux、TimeCesium、 

TimeHub、TimePictra、TimeProvider、TrueTime、WinPath 和 ZL 均为 Microchip Technology Incorporated 在美国的

注册商标。

Adjacent Key Suppression、AKS、Analog-for-the-Digital Age、Any Capacitor、AnyIn、AnyOut、Augmented 
Switching、BlueSky、BodyCom、CodeGuard、CryptoAuthentication、CryptoAutomotive、CryptoCompanion、 

CryptoController、dsPICDEM、dsPICDEM.net、Dynamic Average Matching、DAM、ECAN、Espresso T1S、 

EtherGREEN、GridTime、IdealBridge、In-Circuit Serial Programming、ICSP、INICnet、Intelligent Paralleling、 

Inter-Chip Connectivity、JitterBlocker、Knob-on-Display、maxCrypto、maxView、memBrain、Mindi、MiWi、 

MPASM、MPF、MPLAB Certified 徽标、MPLIB、MPLINK、MultiTRAK、NetDetach、NVM Express、NVMe、 

Omniscient Code Generation、PICDEM、PICDEM.net、PICkit、PICtail、PowerSmart、PureSilicon、QMatrix、 

REAL ICE、Ripple Blocker、RTAX、RTG4、SAM-ICE、Serial Quad I/O、simpleMAP、SimpliPHY、SmartBuffer、 

SmartHLS、SMART-I.S.、storClad、SQI、SuperSwitcher、SuperSwitcher II、Switchtec、SynchroPHY、Total 
Endurance、TSHARC、USBCheck、VariSense、VectorBlox、VeriPHY、ViewSpan、WiperLock、XpressConnect
和 ZENA 均为 Microchip Technology Incorporated 在美国和其他国家或地区的商标。

SQTP 为 Microchip Technology Incorporated 在美国的服务标记。

Adaptec 徽标、Frequency on Demand、Silicon Storage Technology、Symmcom 和 Trusted Time 均为 Microchip 
Technology Inc.在除美国外的国家或地区的注册商标。

GestIC 为 Microchip Technology Inc.的子公司 Microchip Technology Germany II GmbH & Co. KG 在除美国外的国家

或地区的注册商标。

在此提及的所有其他商标均为各持有公司所有。

© 2022, Microchip Technology Incorporated 及其子公司版权所有。

ISBN：978-1-5224-9849-0

质量管理体系

有关 Microchip 的质量管理体系的信息，请访问 www.microchip.com/quality。
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公司总部

2355 West Chandler Blvd.
Chandler, AZ 85224-6199
电话：480-792-7200
传真：480-792-7277
技术支持：

www.microchip.com/support
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