
 TB3231
 使用 MPLAB® Harmony v3 的 MPLAB Harmony 配置器
（MHC）在 SAM 单片机上创建“Hello World”应用程序

简介

MPLAB® Harmony v3 是一款软件开发框架，包含兼容且可互操作的模块，包括外设库（Peripheral Library，PLIB）、

驱动程序、系统服务、中间件和第三方库。MPLAB Harmony 配置器（MPLAB Harmony Configurator，MHC）是一款

基于 GUI 的工具，它提供一种简单方法来使能和配置各种 MPLAB Harmony 模块。MHC 是 MPLAB X 集成开发环境

（Integrated Development Environment，IDE）中的一款插件。

本文档介绍如何使用 MHC 通过 MPLAB Harmony v3 模块在基于 Arm® Cortex®
的 SAM 单片机（MCU）上创建一个简

单的应用程序。该应用程序将向计算机上运行的控制台发送“Hello World!”字符串。本演示通过 MHC 使用并配置以

下 MPLAB Harmony v3 模块：

• 时钟 PLIB，使用时钟管理器配置单片机时钟。

• PORT PLIB，使用引脚管理器配置单片机 I/O。

• 串行通信（SERCOM），使用 USART PLIB 将 USART 外设配置为串口。
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1. 创建“Hello World”应用程序
本文档介绍如何使用 MPLAB Harmony v3 MHC 工具在 SAM 器件上创建“Hello World”应用程序。此外，还介绍涉及

下述几个步骤的过程。本演示使用以下软件和硬件工具：

• MPLAB X IDE v5.25
• MHC v3 MPLAB 插件 v3.3.0.1
• XC32 v2.20
• MPLAB Harmony v3 资源库：

– csp v3.4.0
– mhc v3.3.1
– dev_packs v3.4.0

• SAMD21 Xplained Pro 评估板

注： 用户也可以使用以上工具的更新版本来创建应用程序，而不局限于使用旧版本。

步骤 1：要创建基于 MPLAB Harmony v3 的项目，请按照以下步骤操作：

1. 启动 MPLAB X IDE。
2. 在 MPLAB X IDE 中，依次选择 File > New Project（文件 > 新建项目）（或单击 New Project 图标）。

3. 在 New Project 窗口中，选择 Categories（类别）窗格中的 Microchip Embedded（Microchip 已安装工

具），然后选择 Projects（项目）窗格中的 32-bit MPLAB Harmony 3 Project（32 位 MPLAB Harmony 3 项

目）。

注： 如果选项 32-Bit MPLAB Harmony v3 Project 不可用，请依次选择 Tools > Plugins > Available Plugins（工

具 > 插件 > 可用插件）以安装 MPLAB Harmony v3 配置器插件，然后继续本演示。可从 https://
microchipdeveloper.com/harmony3:mhc-overview 下载 MPLAB Harmony v3 配置器概述。

图 1-1. 创建基于 MPLAB Harmony v3 的项目——Choose Project（选择项目）
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4. 单击 Next（下一步）。

5. 在 Manage Framework（管理框架）部分下，输入 Framework Path（框架路径）（用于下载 MPLAB
Harmony v3 软件包的文件夹路径）。在本演示中，MPLAB Harmony v3 软件包下载在以下位置：D:\microchip
\github\h3。
图 1-2. 创建基于 MPLAB Harmony v3 的项目——Framework Selection（框架选择）

注： 本演示应用程序需要以下 MPLAB Harmony v3 软件包：mhc、dev_packs 和 csp。MPLAB Harmony 3 内

容管理器工具可简化下载 MPLAB Harmony v3 软件包的过程。如果用户尚未下载这些软件包，则可以使用

MPLAB Harmony 3 内容管理器工具将软件包下载到计算机上。

6. 单击 Next。
7. 在 Name and Location（名称和位置）部分下，输入以下详细信息：

– Location（位置）：指示新项目的根文件夹路径。所有项目文件都将放在此文件夹中。项目位置可以是任

何有效路径，例如：D:\microchip\github\h3\tech_brief。
– Folder（文件夹）：指示 MPLAB X IDE 文件夹的名称。输入 hello_world 以创建 hello_world.X文件

夹。

– Name（名称）：输入 hello_world_sam_d21_xpro 作为项目名称。此名称将显示在 MPLAB X IDE 中。

– Path（路径）：当用户更改其他字段时，路径信息将会更新。
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图 1-3. 创建基于 MPLAB Harmony v3 的项目——Project Settings（项目设置）

注： 单击 Show Visual Help（显示可视化帮助）按钮可打开上下文帮助窗口，其中提供有关 Project Settings
中的各个字段的详细说明。

8. 单击 Next。
9. 在 Configuration Settings（配置设置）部分下，输入以下详细信息：

– Name：输入 sam_d21_xpro 作为配置名称。

– Target Device（目标器件）：选择 ATSAMD21J18A。
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图 1-4. 创建基于 MPLAB Harmony v3 的项目——Configuration Settings（配置设置）

注： 单击 Show Visual Help 按钮可打开上下文帮助窗口，其中提供有关 Configuration Settings 中的各个字段

的详细说明。

10. 单击 Finish（完成）以启动 MHC。

注： 单击 Finish 按钮后，如果 MHC 未启动，用户可以从 MPLAB X IDE 依次选择 Tools > Embedded >
MPLAB® Harmony 3 Configurator（工具 > 已安装工具 > MPLAB® Harmony 3 配置器）来启动它。

11. 启动 MHC 之前，系统将显示 Configuration Database Setup（配置数据库设置）窗口，可以根据需要在该窗口

中更改器件系列包（Device Family Pack，DFP）和 Cortex 单片机软件接口（Cortex Microcontroller Software
Interface Standard，CMSIS）路径。本演示使用默认设置。

图 1-5. Configuration Database Setup 窗口

12. 单击 Launch（启动）。

13. 系统将在新窗口中打开 MHC 插件。下图突出显示了 MHC 中包含的不同部分。
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图 1-6. MPLAB Harmony v3 配置器窗口

Available 
Components

Active 
Components Project Graph

Console

Tree View 
Configuration

Generate 
Code

注： 在本演示中，通过依次选择 Tools > Options > Plugins > MPLAB Harmony 3 Configurator> Window
Manager（工具 > 选项 > 插件 > MPLAB Harmony 3 配置器 > 窗口管理器）来更改 MPLAB X IDE 中的设置，

从而将独立模式用于 MHC 窗口管理器。如果需要使用 MHC 的 Native Netbert 模式，用户可以通过配置将其设

置为默认模式。

14. 有关 MHC 以及如何创建 MPLAB Harmony v3 项目的其他信息，请访问：https://microchipdeveloper.com/
harmony3:mhc-overview。

步骤 2：要使用 MHC 添加和配置 MPLAB Harmony 组件，请按照以下步骤操作：

1. 在 Tools（工具）中，选择 Clock Configuration（时钟配置）以启动 Clock Easy View（时钟简单视图）。

图 1-7. MPLAB Harmony 配置器 Tools 菜单

系统将在 MHC 窗口中显示 Clock Easy View 窗口。

2. 在 Clock Easy View 窗口中，向右滚动并验证 Main Clock（主时钟）是否设置为 48 MHz。
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图 1-8. MPLAB Harmony v3 时钟配置器——Clock Easy View 窗口

3. 要添加和配置 USART 外设库，请按照以下步骤操作：

– 在 Available Components（可用组件）下，展开 Peripherals（外设），然后展开 SERCOM 的可用选项。

– 双击 SERCOM3 以将其添加到项目

图 1-9. MHC Available Components 窗口

4. 在 Project Graph（项目图）中选择 SERCOM3 Peripheral Library（SERCOM3 外设库），然后在

Configuration Options（配置选项）窗口中，按以下步骤进行配置：

– 将 SERCOM 操作模式设置为 USART with Internal Clock（具有内部时钟的 USART）（默认设置）。

– 清除 Receive Enable（允许接收），因为此示例中将仅发送字符串。

– 将 Baud Rate（波特率）设置为 9600。
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– 对于 Transmit Pinout（发送引脚排列），选择 SERCOM PAD[0]（默认设置）。

– 默认情况下，Receive Pinout（接收引脚排列）为 SERCOM PAD[0]。如果禁用 Receive Pinout 功能，不

会对操作产生影响。

图 1-10. MHC SERCOM 配置

5. 在 Pin Settings（引脚设置）中配置 USART 引脚：在 MHC 中，依次选择 Tools > Pin Configuration（工具 > 引
脚配置）以打开 Pin Settings 窗口。

图 1-11. MHC Pin Configuration

6. 系统将打开 MHC Pin Settings 窗口并显示以下选项：Pin Diagram（引脚图）、Pin Table（引脚表）和 Pin
Settings。
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图 1-12. MHC Pin Settings 窗口

注： 根据 SAMD21 Xplained Pro 评估板的原理图，板上嵌入式调试器（Embedded Debugger，EDBG）可用

作虚拟通信端口，以便在 SAMD21 器件和所连接的计算机控制台之间进行串行通信。因此，必须将 SAMD21
的 PA22（引脚 43）配置为 USART_TX（SERCOM3 PAD0）。

7. 单击 Pin Settings 选项卡，并将 PA22 引脚配置为 SERCOM3_PAD0。
图 1-13. SERCOM Pin Settings 窗口

8. 可通过单击 Pin Table 选项卡来配置同一引脚（PA22）。
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图 1-14. SERCOM Pin Table 窗口

注：

1. USART_TX功能（发送引脚）默认配置在 SERCOM3 PAD0 上，有关其他信息，请参见 MHC
SERCOM 配置。

2. 在 SERCOM3 USART 配置中，仅针对发送功能使能 USART。因此，未配置 USART 接收引脚。

步骤 3：要生成代码，请按照以下步骤操作：

1. 在 MHC 中，单击 Save MHC State（保存 MHC 状态）图标，以在生成代码之前保存 MHC 状态。

图 1-15. Save MHC State 图标

2. 当系统提示时，将配置保存在其默认位置。

3. 单击 Generate Code（生成代码）图标以生成代码。
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图 1-16. MHC Generate Code 图标

4. 系统将提示 Modified Configuration（配置已修改）窗口，单击 Save（保存）以保存配置。

图 1-17. 保存配置

5. 在 Generate Project（生成项目）窗口中，单击 Generate（生成）以生成代码。
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图 1-18. 生成代码

6. 上述步骤会在 MHC 中触发以下操作：

– 根据完成的配置生成代码。

– 将生成的代码和所需的 MPLAB Harmony 框架文件放入 MPLAB Harmony 项目目录中，在本例中，目录路

径为：D:\microchip\github\h3\tech_brief\firmware\src。
– 将生成的所有代码和 MPLAB Harmony 框架文件添加到 MPLAB Harmony 项目中，如下图所示。
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图 1-19. MHC 生成的代码

注： 系统将在另一个窗口中显示 MPLAB Harmony 项目，因为该项目处于独立模式。

7. 有关生成的代码的说明如下：

– definitions.h：包括项目所需的所有头文件。

– initialization.c：初始化应用程序中使用的所有 MPLAB Harmony 模块。

– interrupts.c：包含所选器件上所有中断向量的映射。

– main.c：用于初始化此文件中的系统的函数调用。用户需要在此文件中开发其应用程序。

– peripheral：所有外设源代码都添加到此文件夹中。

注： MHC 提供一个选项来更改生成的文件名，如果未使用该选项，则默认情况下生成文件名 main.c。
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图 1-20. MHC 系统配置

步骤 4：要开发和运行应用程序，请按照以下步骤操作：

1. 开发应用程序：对于本演示应用程序，在 main.c文件中添加突出显示的代码（如下图所示）。这将向 PC 上

运行的控制台发送“Hello World!”字符串。

现提供以下代码以方便您使用：

uint8_t buffer[]= "Hello World!\r\n";

SERCOM3_USART_Write(&buffer[0], sizeof(buffer));

图 1-21. 开发应用程序

Define the string to be printed

Application 
logic

2. 选择硬件工具和编译器：在 MPLAB X IDE Project Properties（项目属性）窗口中，执行以下操作：

3. 在 Categories（类别）部分下，选择 Conf: (sam_d21_xpro)，在 Configuration（配置）部分，选择硬件工具和

编译器工具链。

 TB3231
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图 1-22. MPLAB X IDE Project Properties 窗口

4. 点击 OK（确定）。

5. 连接硬件：用 micro-USB 电缆将板上的 DEBUG USB 与 PC 连接起来，从而可以对单片机进行编程，并提供与

控制台设备（计算机）的串行连接。

图 1-23. 硬件连接

Common USB 
Port for 

Debugging and 
UART Console

6. 设置串行控制台：在 PC 上打开终端应用程序（例如 Tera Term）并执行串口设置。以下是 Tera Term 的默认设

置详细信息。
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图 1-24. 串口设置

7. 编程并运行应用程序：使用 MPLAB X IDE 对 SAMD21 Xplained Pro 工具包进行编译和编程。

图 1-25. 编译与编程

8. 观察输出：观察控制台上是否出现“Hello World!”字符串。如果在控制台上找不到所需输出，请按 Xplained
Pro 评估板上的 Reset（复位）按钮复位器件，并确保传送 UART 消息。

图 1-26. 观察输出
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2. 资源
• 有关 MPLAB Harmony v3 的更多信息，请参见以下 Microchip 网站：

https://www.microchip.com/mplab/mplab-harmony

microchipdeveloper.com/harmony3:start
• 有关各种 MPLAB Harmony v3 组件的详细文档，请参见相应资源库的文档文件夹。

• 有关 SAM D21 Xplained Pro 工具包的详细信息，请参见以下网站：
www.microchip.com/DevelopmentTools/ProductDetails/ATSAMD21-XPRO

 TB3231
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3. 版本历史

版本 B（2020 年 2 月）

更新了排版。

将 MPLAB Harmony 的所有交叉引用更新显示为 MPLAB Harmony v3。

版本 A（2019 年 12 月）

这是本文档的初始发布版本。
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Microchip 网站

Microchip 网站（www.microchip.com/）为客户提供在线支持。客户可通过该网站方便地获取文件和信息。我们的网站

提供以下内容：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及硬件支持文档、最新的软件版
本以及归档软件

• 一般技术支持——常见问题解答（FAQ）、技术支持请求、在线讨论组以及 Microchip 设计伙伴计划成员名单

• Microchip 业务——产品选型和订购指南、最新 Microchip 新闻稿、研讨会和活动安排表、Microchip 销售办事

处、代理商以及工厂代表列表

产品变更通知服务

Microchip 的产品变更通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在他们感兴趣的某个产品系列

或开发工具发生变更、更新、发布新版本或勘误表时，收到电子邮件通知。

欲注册，请访问 www.microchip.com/pcn，然后按照注册说明进行操作。

客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师（ESE）
• 技术支持

客户应联系其代理商、代表或 ESE 寻求支持。当地销售办事处也可为客户提供帮助。本文档后附有销售办事处的联系

方式。

也可通过 www.microchip.com/support 获得网上技术支持。

Microchip 器件代码保护功能

请注意以下有关 Microchip 器件代码保护功能的要点：

• Microchip 的产品均达到 Microchip 数据手册中所述的技术规范。

• Microchip 确信：在正常使用的情况下，Microchip 系列产品非常安全。

• 目前，仍存在着用恶意、甚至是非法的方法来试图破坏代码保护功能的行为。我们确信，所有这些行为都不是以

Microchip 数据手册中规定的操作规范来使用 Microchip 产品的。这种试图破坏代码保护功能的行为极可能侵犯

Microchip 的知识产权。

• Microchip 愿与那些注重代码完整性的客户合作。

• Microchip 或任何其他半导体厂商均无法保证其代码的安全性。代码保护并不意味着我们保证产品是“牢不可破”

的。代码保护功能处于持续发展中。Microchip 承诺将不断改进产品的代码保护功能。任何试图破坏 Microchip 代

码保护功能的行为均可视为违反了《数字器件千年版权法案（Digital Millennium Copyright Act）》。如果这种行

为导致他人在未经授权的情况下，能访问您的软件或其他受版权保护的成果，您有权依据该法案提起诉讼，从而

制止这种行为。

法律声明

提供本文档的中文版本仅为了便于理解。请勿忽视文档中包含的英文部分，因为其中提供了有关 Microchip 产品性能和

使用情况的有用信息。Microchip Technology Inc.及其分公司和相关公司、各级主管与员工及事务代理机构对译文中可

能存在的任何差错不承担任何责任。建议参考 Microchip Technology Inc.的英文原版文档。
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本出版物中提供的信息仅仅是为方便您使用 Microchip 产品或使用这些产品来进行设计。本出版物中所述的器件应用信

息及其他类似内容仅为您提供便利，它们可能由更新之信息所替代。确保应用符合技术规范，是您自身应负的责任。

Microchip“按原样”提供这些信息。Microchip 对这些信息不作任何明示或暗示、书面或口头、法定或其他形式的声明

或担保，包括但不限于针对非侵权性、适销性和特定用途的适用性的暗示担保，或针对其使用情况、质量或性能的担

保。

在任何情况下，对于因这些信息或使用这些信息而产生的任何间接的、特殊的、惩罚性的、偶然的或间接的损失、损

害或任何类型的开销，Microchip 概不承担任何责任，即使 Microchip 已被告知可能发生损害或损害可以预见。在法律

允许的最大范围内，对于因这些信息或使用这些信息而产生的所有索赔，Microchip 在任何情况下所承担的全部责任均

不超出您为获得这些信息向 Microchip 直接支付的金额（如有）。如果将 Microchip 器件用于生命维持和/或生命安全应

用，一切风险由买方自负。买方同意在由此引发任何一切损害、索赔、诉讼或费用时，会维护和保障 Microchip 免于承

担法律责任。除非另外声明，在 Microchip 知识产权保护下，不得暗中或以其他方式转让任何许可证。

商标

Microchip 的名称和徽标组合、Microchip 徽标、Adaptec、AnyRate、AVR、AVR 徽标、AVR Freaks、BesTime、 
BitCloud、chipKIT、chipKIT 徽标、CryptoMemory、CryptoRF、dsPIC、FlashFlex、flexPWR、HELDO、IGLOO、 
JukeBlox、KeeLoq、Kleer、LANCheck、LinkMD、maXStylus、maXTouch、MediaLB、megaAVR、Microsemi、 
Microsemi 徽标、MOST、MOST 徽标、MPLAB、OptoLyzer、PackeTime、PIC、picoPower、PICSTART、PIC32徽
标、PolarFire、Prochip Designer、QTouch、SAM-BA、SenGenuity、SpyNIC、SST、SST 徽标、SuperFlash、 
Symmetricom、SyncServer、Tachyon、TimeSource、tinyAVR、UNI/O、Vectron 及 XMEGA 均为 Microchip 
Technology Incorporated 在美国和其他国家或地区的注册商标。

AgileSwitch、APT、ClockWorks、The Embedded Control Solutions Company、EtherSynch、FlashTec、Hyper 
Speed Control、HyperLight Load、IntelliMOS、Libero、motorBench、mTouch、Powermite 3、Precision Edge、 
ProASIC、ProASIC Plus、ProASIC Plus 徽标、Quiet-Wire、SmartFusion、SyncWorld、Temux、TimeCesium、 
TimeHub、TimePictra、TimeProvider、WinPath 和 ZL 均为 Microchip Technology Incorporated 在美国的注册商标。

Adjacent Key Suppression、AKS、Analog-for-the-Digital Age、Any Capacitor、AnyIn、AnyOut、Augmented 
Switching、BlueSky、BodyCom、CodeGuard、CryptoAuthentication、CryptoAutomotive、CryptoCompanion、 
CryptoController、dsPICDEM、dsPICDEM.net、Dynamic Average Matching、DAM、ECAN、Espresso T1S、 
EtherGREEN、IdealBridge、In-Circuit Serial Programming、ICSP、INICnet、Intelligent Paralleling、Inter-Chip 
Connectivity、JitterBlocker、maxCrypto、maxView、memBrain、Mindi、MiWi、MPASM、MPF、MPLAB Certified徽
标、MPLIB、MPLINK、MultiTRAK、NetDetach、Omniscient Code Generation、PICDEM、PICDEM.net、 
PICkit、PICtail、PowerSmart、PureSilicon、QMatrix、REAL ICE、Ripple Blocker、RTAX、RTG4、SAM-ICE、 
Serial Quad I/O、simpleMAP、SimpliPHY、SmartBuffer、SMART-I.S.、storClad、SQI、SuperSwitcher、 
SuperSwitcher II、Switchtec、SynchroPHY、Total Endurance、TSHARC、USBCheck、VariSense、VectorBlox、 
VeriPHY、ViewSpan、WiperLock、XpressConnect 和 ZENA 均为 Microchip Technology Incorporated 在美国和其他
国家或地区的商标。

SQTP 为 Microchip Technology Incorporated 在美国的服务标记。

Adaptec 徽标、Frequency on Demand、Silicon Storage Technology 和 Symmcom 均为 Microchip Technology Inc.在
除美国外的国家或地区的注册商标。

GestIC 为 Microchip Technology Inc.的子公司 Microchip Technology Germany II GmbH & Co. KG 在除美国外的国家

或地区的注册商标。

在此提及的所有其他商标均为各持有公司所有。

© 2020，Microchip Technology Incorporated 版权所有。

ISBN：978-1-5224-6854-7

AMBA、Arm、Arm7、Arm7TDMI、Arm9、Arm11、Artisan、big.LITTLE、Cordio、CoreLink、CoreSight、Cortex、 

DesignStart、DynamIQ、Jazelle、Keil、Mali、Mbed、Mbed Enabled、NEON、POP、RealView、SecurCore、 

Socrates、Thumb、TrustZone、ULINK、ULINK2、ULINK-ME、ULINK-PLUS、ULINKpro、µVision 和 Versatile 均为

Arm Limited（或其子公司）在美国和/或其他国家/地区的商标或注册商标。
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质量管理体系

有关 Microchip 的质量管理体系的信息，请访问 www.microchip.com/quality。
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公司总部

2355 West Chandler Blvd.
Chandler, AZ 85224-6199
电话：480-792-7200
传真：480-792-7277
技术支持：

www.microchip.com/support
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www.microchip.com
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台湾地区 - 高雄
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